杭电2717Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9932    Accepted Submission(s): 3109


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

Source
 

Recommend
teddy   |   We have carefully selected several similar problems for you:   2102  1372  1240  1072  1180 
 


广搜,感觉自己变傻逼了,这都不会了。

#include<stdio.h>
#include<queue>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
	int start;
	int time;
}a,team;
int vist[110000],i,j,k,l,m,n,end,best;
void bfs(int num)
{
	queue<node > q;
	a.start=num;
	a.time =0;
	q.push(a);
	memset(vist,0,sizeof(vist));
	vist[a.start]=1;
	while(!q.empty())
	{
		a=q.front();
		q.pop();
		for(i=0;i<3;i++)
		{
			if(i==0)
			team.start =a.start +1;
			if(i==1)
			team.start =a.start -1;
			if(i==2)
			team.start =a.start *2;
			team.time =a.time +1;
		if(team.start ==n)
		{
			if(best>=team.time)
			best=team.time;
		}
		if(team.start>100000||team.start <0)
		continue;
		if(!vist[team.start])
		{
		vist[team.start]=1;
		q.push(team);
		}
		}
	}
}
int main()
{
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		best=99999;
		if(n<=m)
		{
		printf("%d\n",m-n);
		continue;
		}
		bfs(m);
		printf("%d\n",best);
	}
	return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值