杭电2714&&poj2190 ISBN

ISBN

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1306    Accepted Submission(s): 389


Problem Description
Farmer John's cows enjoy reading books, and FJ has discovered that his cows produce more milk when they read books of a somewhat intellectual nature. He decides to update the barn library to replace all of the cheap romance novels with textbooks on algorithms and mathematics. Unfortunately, a shipment of these new books has fallen in the mud and their ISBN numbers are now hard to read.

An ISBN (International Standard Book Number) is a ten digit code that uniquely identifies a book. The first nine digits represent the book and the last digit is used to make sure the ISBN is correct. To verify that an ISBN number is correct, you calculate a sum that is 10 times the first digit plus 9 times the second digit plus 8 times the third digit ... all the way until you add 1 times the last digit. If the final number leaves no remainder when divided by 11, the code is a valid ISBN.

For example 0201103311 is a valid ISBN, since
10*0 + 9*2 + 8*0 + 7*1 + 6*1 + 5*0 + 4*3 + 3*3 + 2*1 + 1*1 = 55.

Each of the first nine digits can take a value between 0 and 9. Sometimes it is necessary to make the last digit equal to ten; this is done by writing the last digit as X. For example, 156881111X is a valid ISBN number.

Your task is to fill in the missing digit from a given ISBN number where the missing digit is represented as '?'.
 

Input
* Line 1: A single line with a ten digit ISBN number that contains '?' in a single position
 

Output
* Line 1: The missing digit (0..9 or X). Output -1 if there is no acceptable digit for the position marked '?' that gives a valid ISBN.
 

Sample Input
  
  
15688?111X
 

Sample Output
  
  
1
 

Source
 

Recommend
teddy   |   We have carefully selected several similar problems for you:   2715  2716  2709  2710  2713 
 
我承认做的时候突然傻逼了一下,然后厚着脸皮去问大神,虽然大神并没有给我解答。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[110];
int i,j,k,l,m,n;
int main()
{
	while(scanf("%s",s)!=EOF)
	{
		int sum=0;
		l=strlen(s);
		for(i=0;i<l;i++)
		{
			if(s[i]>='0'&&s[i]<='9')
			sum+=(s[i]-'0')*(10-i);
			if(s[i]=='X')
			sum+=10*(10-i);
			if(s[i]=='?')
			k=i;
		}
		if(k==9)
		{
			for(i=0;i<11;i++)
			if((sum+i*(10-k))%11==0)
			{
				if(i==10)
				printf("X\n");
				else
				printf("%d\n",i);
				break;
			}
			if(i==11)
			printf("-1\n");
		}
		else if(k<9)
		{
			for(i=0;i<10;i++)
			if((sum+i*(10-k))%11==0)
			{
				printf("%d\n",i);	
				break;
			}
			if(i==10)
			printf("-1\n");
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值