杭电1501 hdu1501 Zipper(深搜dfs)

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8426    Accepted Submission(s): 2975


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1502  1227  1158  1080  1503 
 


看来深搜理解的并不是灰常透彻,原来标记之后又回退了一下,导致超时了,后来看了一下程序,不需要回退:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int vis[1100][1100],i,j,k,l,m,n,len,lem,num;
char s[1100],c[1100],sh[1100];
void dfs(int i,int j,int k)
{
	if(sh[k]=='\0')
	{
		num=1;
		return ;
	}
	if(num)
	return ;
	if(vis[i][j])
	return ;
	if(sh[k]!=s[i]&&sh[k]!=c[j])//匹配不住直接结束 
	return ;
	if(sh[k]==s[i]&&i<len)//如果跟第一个匹配住了 ,标记这点用过了 
	{
		vis[i][j]=1;
		dfs(i+1,j,k+1);//搜索下一个点 
	}
	if(sh[k]==c[j]&&j<lem)//如果跟第二个匹配住了,标记这点用过了 
	{
		vis[i][j]=1;
		dfs(i,j+1,k+1);//搜索下一个点 
	}
}
int main()
{
	scanf("%d",&k);
	int cnt=1;
	while(k--)
	{
		scanf("%s%s%s",s,c,sh);
		memset(vis,0,sizeof(vis)); 
		len=strlen(s);
		lem=strlen(c);
		l=strlen(sh);
		if(l!=len+lem)
		{
			printf("Data set %d: no\n",cnt++);
			continue;	
		}
		num=0;
		dfs(0,0,0);
		if(num)
		printf("Data set %d: yes\n",cnt++);
		else
		printf("Data set %d: no\n",cnt++);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值