郁闷的C小加(一)
时间限制:
1000 ms | 内存限制:
65535 KB
难度:3
-
描述
-
我们熟悉的表达式如a+b、a+b*(c+d)等都属于中缀表达式。中缀表达式就是(对于双目运算符来说)操作符在两个操作数中间:num1 operand num2。同理,后缀表达式就是操作符在两个操作数之后:num1 num2 operand。ACM队的“C小加”正在郁闷怎样把一个中缀表达式转换为后缀表达式,现在请你设计一个程序,帮助C小加把中缀表达式转换成后缀表达式。为简化问题,操作数均为个位数,操作符只有+-*/ 和小括号。
-
输入
-
第一行输入T,表示有T组测试数据(T<10)。
每组测试数据只有一行,是一个长度不超过1000的字符串,表示这个表达式。这个表达式里只包含+-*/与小括号这几种符号。其中小括号可以嵌套使用。数据保证输入的操作数中不会出现负数。并且输入数据不会出现不匹配现象。
输出
- 每组输出都单独成行,输出转换的后缀表达式。 样例输入
-
21+2(1+2)*3+4*5
样例输出
-
12+12+3*45*+
-
第一行输入T,表示有T组测试数据(T<10)。
类似于表达式求值的做法,用栈来做。
#include<stdio.h>
#include<stack>
#include<string.h>
#include<queue>
using namespace std;
stack<char>operStack;
queue<char>ansQueue;
char str[1010];
int main()
{
int t,i;
scanf("%d",&t);
while(t--)
{
i=0;
scanf("%s",str);
while(str[i]!='\0')
{
if(str[i]>='0'&&str[i]<='9')
{
ansQueue.push(str[i]);
}
else if(str[i]=='+'||str[i]=='-')
{
while(!operStack.empty()&&operStack.top()!='(') //如果是+,-符号并且前面还有操作符则可以将前面的操作符加入队列
{
char ch=operStack.top();
operStack.pop();
ansQueue.push(ch);
}
operStack.push(str[i]);
}
else if(str[i]=='*'||str[i]=='/')
{
while(!operStack.empty()&&(operStack.top()=='*'||operStack.top()=='/'))//如果是*,/符号并且前面的操作符是*,/则可以将前面的操作符加入队列
{
char ch=operStack.top();
operStack.pop();
ansQueue.push(ch);
}
operStack.push(str[i]);
}
else if(str[i]=='(')
{
operStack.push('(');
}
else if(str[i]==')')
{
while(operStack.top()!='(')
{
char ch=operStack.top();
operStack.pop();
ansQueue.push(ch);
}
operStack.pop();
}
i++;
}
while(!operStack.empty())
{
if(operStack.top()=='(')
{
operStack.pop();
continue;
}
char ch=operStack.top();
operStack.pop();
ansQueue.push(ch);
}
while(!ansQueue.empty())
{
char ch=ansQueue.front();
ansQueue.pop();
printf("%c",ch);
}
printf("\n");
}
return 0;
}
/*
4
1
(2*(2+3))
4+4*5/(3+1)
(1+2)*3+4*5
*/