7-18 统计大写辅音字母
分数 15
全屏浏览题目
切换布局
作者 C课程组
单位 浙江大学
英文辅音字母是除A
、E
、I
、O
、U
以外的字母。本题要求编写程序,统计给定字符串中大写辅音字母的个数。
输入格式:
输入在一行中给出一个不超过80个字符、并以回车结束的字符串。
输出格式:
输出在一行中给出字符串中大写辅音字母的个数。
输入样例:
HELLO World!
输出样例:
4
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
参考答案
#include <stdio.h>
#include <ctype.h>
int main() {
char str[81];
int count = 0;
gets(str);
for (int i = 0; str[i] != '\0'; i++) {
if (isupper(str[i]) && tolower(str[i]) != 'a' && tolower(str[i]) != 'e' && tolower(str[i]) != 'i' && tolower(str[i]) != 'o' && tolower(str[i]) != 'u') {
count++; //不用tolower也行x
}
}
printf("%d\n", count);
return 0;
}