数据结构C++版 王红梅 OJ习题

1036: 直接插入排序

Description

已知直接插入排序的部分代码如下,勿改动,请补充实现插入排序函数。要求输出每趟排序结果。

#include<iostream>
using namespace std;
const int MaxSize=100;
class List
{
private:
 int r[MaxSize+1];
 int n;
public:
    List(){n=0;} //empty list
 void InsertR(int k)  //表尾插入
 {  r[++n]=k;}
 void Display();      //display
 void InsertSort();   //InsertSort
};
void List::Display()
{
 for(int i=1;i<=n;i++)
       cout<<r[i]<<" ";  
 cout<<"\n";
}
int main()
{
 List L;
 while(1)
 {
  int k;
  cin>>k;
  if(!k) break;
        L.InsertR(k);
 }
 //L.Display();
 L.InsertSort();
 //L.Display();
 return 0;
}

Input

Output

Sample Input

12 21 32 2 4 24 21 432 23 9 0

Sample Output

12 21 32 2 4 24 21 432 23 9 
12 21 32 2 4 24 21 432 23 9 
2 12 21 32 4 24 21 432 23 9 
2 4 12 21 32 24 21 432 23 9 
2 4 12 21 24 32 21 432 23 9 
2 4 12 21 21 24 32 432 23 9 
2 4 12 21 21 24 32 432 23 9 
2 4 12 21 21 23 24 32 432 9 
2 4 9 12 21 21 23 24 32 432 
//
// Created by Legends丶Hu on 2020/2/6.
//

#include<iostream>

using namespace std;
const int MaxSize = 100;

class List {
private:
    int r[MaxSize + 1];
    int n;
public:
    List() { n = 0; } //empty list
    void InsertR(int k)  //表尾插入
    { r[++n] = k; }

    void Display();      //display
    void InsertSort();   //InsertSort
};

void List::Display() {
    for (int i = 1; i <= n; i++)
        cout << r[i] << " ";
    cout << "\n";
}

void List::InsertSort() {
    int j;
    for (int i = 2; i <= n; i++) {
        r[0] = r[i];
        for (j = i - 1; r[0] < r[j]; j--) {
            r[j + 1] = r[j];
        }
        r[j + 1] = r[0];
        Display();
    }

}
/*
 * 12 21 32 2 4 24 21 432 23 9 0
 */
int main() {
    List L;
    while (1) {
        int k;
        cin >> k;
        if (!k) break;
        L.InsertR(k);
    }
    L.InsertSort();
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值