题目描述
不借用任何字符串库函数实现无冗余地接受两个字符串,然后把它们无冗余的连接起来。
输入
每一行包括两个字符串,长度不超过100。
输出
可能有多组测试数据,对于每组数据,
不借用任何字符串库函数实现无冗余地接受两个字符串,然后把它们无冗余的连接起来。
输出连接后的字符串。
样例输入 Copy
abc def
样例输出 Copy
abcdef
#include<cstdio>
const int maxn=101;
int main(){
char str1[maxn];
char str2[maxn];
while(scanf("%s%s",str1,str2)!=EOF){
char a[2*maxn];
int i=0,j=0;
while(str1[i]!='\0'){
a[i]=str1[i];
i++;
}
while(str2[j]!='\0'){
a[i]=str2[j];
j=j+1;
i=i+1;
}
a[i]='\0';
printf("%s\n",a);
}
return 0;
}
字符串后面一定要加’\0’这样printf才能判断到这里结束了,否则会出现问题。