HDU 1003 Max Sum

Max Sum

                                    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

    
    
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

Sample Output

    
    
Case 1:
14 1 4
7 1 6
Case 2:
 

   
   
 题目大意:给你一组数,求出连续子串序列的的最大和,并且求出起始位置和结束位置。

分析:这个题我把它分成了两部分,一部分是输入的数全为负数的时候,这个时候只需要逐个查找直到找到最大的值就可以了,并且记录下标;另一部分存在正整数,用sum记录最大值,并用x,y记录当前区间。

#include<stdio.h>
#include<string.h>
int a[100001];
int main()
{
    int n,t=0;
    scanf("%d",&n);
    while(n--)
    {

        memset(a,0,sizeof(a));
        int s=0,sum=0,i,m,z=0,y=0,x=0,f,k=0;
        scanf("%d",&m);
        for(i=1; i<=m; i++)
            scanf("%d",&a[i]);
        for(i=1; i<=m; i++)
        {
            s+=a[i];
            if(s>sum)       
            {
                sum=s;       //求出区间最大值
                y=i;         //记录区间下标
                x=z+1;
            }
            if(s<0)     //如果s小于0,重新查找新的区间
            {
                s=0;
                z=i;        
            }
        }
        if(t)
            printf("\n");
        printf("Case %d:\n",++t);
        if(sum==0)      //如果全为负数
        {
            f=a[1];
            k=1;
            for(i=2; i<=m; i++)
                if(a[i]>f)    //查找最大数
                {
                    f=a[i];
                    k=i;          //记录下标
                }
            printf("%d %d %d\n",f,k,k);
            continue;
        }

        printf("%d %d %d\n",sum,x,y);

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值