1107 Social Clusters (30分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
#include<iostream>
#include<algorithm>
#include<unordered_map>
#include<vector>
using namespace std;
vector<int> vec;
int fa[1001];
int find_father(int num){

    while (num != fa[num])
    {
        num = fa[num];
    }
    
    return num;
}

void unoin_set(int a, int b){
    int fa_a = find_father(a);
    int fa_b = find_father(b);

    if(fa_a != fa_b)
        fa[fa_a] = fa_b;


}
bool cmp(int a, int b){
    return a > b;
}
int main(){
    int n;
    cin >> n;
    vec.resize(n);
    unordered_map<int, int> un_map;
    for(int i = 0; i < 1001; i++){
        fa[i] = i;
    }
    for(int i = 0; i < n; i++){
        int k;
        scanf("%d: ", &k);
        int pre;
        scanf("%d", &pre);
        vec[i] = pre;
        if(k > 1){ 
            for(int j = 1; j < k; j++){
                int temp;
                scanf("%d", &temp);
                unoin_set(pre, temp);
            }
        }
        

    }

    for(int i = 0; i < n; i++){
        int temp_fa = find_father(vec[i]);
        un_map[temp_fa]++;

    }
    printf("%d\n", int(un_map.size()));
    int a[1001];
    int temp_i = 0;
    for(auto it : un_map){

        a[temp_i] = it.second;
        temp_i++;
    }
    sort(a, a + int(un_map.size()), cmp);

    for(int i = 0; i < int(un_map.size()); i++){

        printf("%s%d", i == 0 ? "" : " ", a[i]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值