1074 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every Kelements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

坑点:最后一个测试节点,不要使用提供的n直接计算,会有多余的节点给到,所以,需要遍历一边链表,看看到底有多少个节点为有效节点。

#include<iostream>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;

int main(){

    int start, n, k;
    cin >> start >> n >> k;
    int list_data[100001];
    int list[100001];
    for(int i = 0; i < n; i++)
    {
        int a, data, b;
        scanf("%d %d %d", &a, &data, &b);
        list[a] = b;
        list_data[a] = data;
    }
    vector<vector<int> > vec;
    int vec_size = ceill(1.0 * n / k);
    vec.resize(vec_size);
    int flag = -1;
    int cnt = 0;
    for(int i = 0; start != -1; i++){
        if(i % k == 0){

            flag++;
            
        }
        vec[flag].push_back(start);

        start = list[start];
        cnt++;

    }

    bool out_flag = true;
    if(cnt % k == 0){
        out_flag = false;
    }
    for(int i = 0; i < vec_size - 1; i++){
        for(int j = vec[i].size() - 1; j >= 1; j--){

            printf("%05d %d %05d\n", vec[i][j], list_data[vec[i][j]], vec[i][j - 1]);
        }
        if(i == vec_size - 2 && out_flag){
            printf("%05d %d %05d\n", vec[i][0], list_data[vec[i][0]], vec[i + 1][0]);
        }        
        else
        {
            printf("%05d %d %05d\n", vec[i][0], list_data[vec[i][0]], vec[i + 1][vec[i].size() - 1]);
        }
        

    }
    if(out_flag){


        for(int j = 0 ; j < vec[vec_size - 1].size() - 1; j++){

            printf("%05d %d %05d\n", vec[vec_size - 1][j], list_data[vec[vec_size - 1][j]], vec[vec_size - 1][j + 1]);
        }
        printf("%05d %d -1\n", vec[vec_size - 1][vec[vec_size - 1].size() - 1], list_data[vec[vec_size - 1][vec[vec_size - 1].size() - 1]]);

    }else
    {
        for(int j = vec[vec_size - 1].size() - 1; j >= 1; j--){

            printf("%05d %d %05d\n", vec[vec_size - 1][j], list_data[vec[vec_size - 1][j]], vec[vec_size - 1][j - 1]);
        }
        printf("%05d %d -1\n", vec[vec_size - 1][0], list_data[vec[vec_size - 1][0]]);
    }
    
    

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值