1063 Set Similarity (25分)

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意:求两个集合相似度,分子为相同的元素个数(去重),分母为总共的元素个数(去重)

#include<unordered_set>
#include<iostream>
#include<vector>

using namespace std;

int main(){

    int n;
    cin >> n;
    vector<unordered_set<int> > vec (n + 1);
    for(int i = 1; i <= n; i++){
        int m;
        scanf("%d", &m);
        for(int j = 0; j < m; j++){
            int temp;
            scanf("%d", &temp);
            vec[i].insert(temp);

        }


    }
    int k;
    cin >> k;
    for(int i = 0; i < k; i++){

        int a, b;
        scanf("%d %d", &a, &b);
        int nc = 0;
        int nt = 0;
        for(auto it : vec[a]){
    
            if(vec[b].find(it) != vec[b].end()){
                nc++;
            } 
        }
        nt = vec[a].size() + vec[b].size() - nc;
        float result = 1.0 * nc / nt * 100;
        printf("%.1f%%\n", result);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值