HDU 1370-Biorhythms + 中国剩余定理

本文分为两个部分:1、HDU1370题解,2、中国剩余定理的推导。

目录:

1:HDU-1370

2:中国剩余定理的推导


 

1:HDU-1370

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6122    Accepted Submission(s): 2384

Problem Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1. 

 

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1. 

 

Sample Input

1

0 0 0 0

0 0 0 100

5 20 34 325

4 5 6 7

283 102 23 320

203 301 203 40

-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.

Case 2: the next triple peak occurs in 21152 days.

Case 3: the next triple peak occurs in 19575 days.

Case 4: the next triple peak occurs in 16994 days.

Case 5: the next triple peak occurs in 8910 days.

Case 6: the next triple peak occurs in 10789 days.

 

Source

East Central North America 1999; Pacific Northwest 1999

 

题意:

给你p,e,i,d 4个整数,已知(n+d)%23=p; (n+d)%28=e; (n+d)%33=i ,让你求出n的最小整数解

题解:

已知:

代码:

#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<cstdio>
#include<ctime>
#include<iostream>
#include<algorithm>
#include<map>
#include<cmath>
typedef long long ll;
using namespace std;
const ll mod=21252;
ll N;
ll p,e,i,d,x,y,z;
ll T,a,b;
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}
void findd()
{
    ll i;
    //求X
    for(i=1,N=28*33;; ++i)
    {
        if(i*N%23==1)
            break;
    }
    x=N*i;

    //求y
    for(i=1,N=23*33;; i++)
    {
        if(i*N%28==1)
            break;
    }
    y=N*i;

    //求z
    for(i=1,N=23*28;; ++i)
    {
        if(i*N%33==1)
            break;
    }
    z=N*i;

    N=23*28*33;
    return ;
}
int main()
{
    findd();
    cin>>T;
    bool flag=false;
    while(T--)
    {
        int number=1;
        getchar();
        if(flag) printf("\n");
        while(~scanf("%lld%lld%lld%lld",&p,&e,&i,&d))
        {
            if(p==-1&&e==-1&&i==-1&&d==-1)
                break;
            ll puts=(x*p+y*e+z*i)%N-d;
            puts=(puts+mod-1)%mod+1;
            printf("Case %d: the next triple peak occurs in %lld days.\n",number++,puts);
        }
        flag=true;
    }
    return 0;
}

 

2:中国剩余定理的推导

首先呢,从一个民间传说开始。

淮安民间传说着一则故事——“韩信点兵”,其次有成语“韩信点兵,多多益善”。韩信带1500名兵士打仗,战死四五百人,站3人一排,多出2人;站5人一排,多出4人;站7人一排,多出6人。韩信很快说出人数:1049。

上面这段话的意思就是:(其中n代表的是总人数)

n%3=2
n%5=4
n%7=6

由于数据较小,我们可以直接使用枚举的方法求出答案,可是如果说数据很大我们不能采用暴力的方法,又该怎么办呢?

这个时候中国剩余定理就来了。。。

70*a%3=2并且70*a%5=0,70*a%7=0

同理,我们可以得到b=1,c=1,他们对应的值分别为21和15

n=(70*2+21*3+15*2)%lcm(3,5,7)=23

也就是我们要求一个数num1,就比如5*7*a%3=1得到的70,对于这个70,它对5和7进行取余后结果都是0

再让这个num1*2(注意,前面出现的是n%3=2,因为我们得到的num1是基于num1%3=1的基础之上的)

接下来(num1*2+num2*3+num3=2)%lcm(3,5,7)=总人数

总结起来就是分为三步:(对于上面的数据来说)

1:求num1,num2,num3......

2:计算num=(num1*余数1+num2*余数2+num3*余数3......)

3:   计算num%lcm(取余数1,,取余数2,..........)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值