hdu1070 milk 贪心

Problem Description

Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.


Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.


Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
 


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
 


Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
 


Sample Input
2
2
Yili 10 500
Mengniu 20 1000
4
Yili 10 500
Mengniu 20 1000
Guangming 1 199
Yanpai 40 10000
 


Sample Output
Mengniu
Mengniu

题意:给出牛奶的单价和体积,每天喝200毫升,不购买小于200毫升的,并且一瓶牛奶最多喝5天,当小于200毫升时扔掉不要,

          求出最便宜的牛奶输出,这时可以先求出每天喝200毫升的花费进行比较


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct p
{
    char s[101];
    double price,v;
    int day;
    double money;
} x[101];
bool cmp(p a,p b)
{
    if(a.money>b.money)
        return a.money<b.money;
    else if(a.money==b.money)
        return a.v>b.v;//价格相等,选择体积大的 
}
int main()
{
    int n,i,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(x,0,sizeof(x));//初始化 
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%s%lf%lf",x[i].s,&x[i].price,&x[i].v);
           if(x[i].v>=200) //体积小于200不考虑 
            {
                x[i].day=x[i].v/200;//可以喝的时间 
                if(x[i].day>5)
                    x[i].day=5;//无论体积多少,最多只可以喝五天 
                x[i].money=x[i].price*1.0/x[i].day;//每天的平均花费 
            }
        }
        sort(x,x+n,cmp);
        for(i=0; i<n; i++)
        {
            if(x[i].money!=0)     //排除体积小于200的情况,当体积小于200时x[i].money为0 
            {
                printf("%s\n",x[i].s);
                break;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值