poj 2431 Expedition

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.




题目的意思就是给出几组可以加油的地方到终点的距离,和这个地方可以加的油量,再给出你总路程和开始的所含的油量,求出到终点最少加几次油,如果不能到终点则输出-1

#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;
struct stop
{
    int x,v;
} s[10010];
bool comp(stop s1,stop s2)
{
    return s1.x<s2.x;
}
int main()
{
    int n,i,l,p;
    while(~scanf("%d",&n))
    {
        for(i=0; i<n; i++)
            scanf("%d%d",&s[i].x,&s[i].v);
        scanf("%d%d",&l,&p);
        for(i=0; i<n; i++)
            s[i].x=l-s[i].x;//把加油站到终点的距离转化为加油站到起点的距离
        s[n].x=l;
        s[n].v=0; //把终点也看作加油站
        sort(s,s+n,comp);//距离从小到大排序
        priority_queue<int,vector<int>,less<int> >Q; //加油量从大到小排序
        int rest=p;   //记录剩余流量
        int ans=0;    //记录加油次数
        int pos=0;     //记录车所行驶到的位置
        for(i=0; i<=n; i++)
        {
            int dis=s[i].x-pos; //从上一个加油站到下一个加油站的距离
            while(rest-dis<0)  //剩余的油不能到此
            {
                if(Q.empty()) //在它之前没有油可以加
                {
                    ans=-1;  //ans标记为-1,代表不能到达终点
                    break;
                }
                rest+=Q.top(); //有油可加
                Q.pop();  //将加过的油删除,不能加第二次
                ans++;
            }
            if(ans==-1)
                break;
            rest=rest-dis;
            pos=s[i].x;
            Q.push(s[i].v);
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值