poj 1836 Alignment 最长递增子序列

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4


题意:让士兵排成一行,求出最少删除几个士兵之后,每个士兵都可以看到最左边或者最右边

借用一个图哈吐舌头

下图:


 

因为要的是每个士兵可以看到最左或最右,是一个或者关系,所以 蓝色士兵的身高和红色士兵的身高是完全没有关系的,

只需要从前,从后各找到一个递增子序列就OK了

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int dp1[1010],dp2[1010];
int n;
double a[1010];
void longer_qian()  //从最前开始的递增子序列
{
    for(int i=0; i<n; i++)
    {
        dp1[i]=1;
        for(int j=0; j<i; j++)
            if(a[i]>a[j])
                dp1[i]=max(dp1[i],dp1[j]+1);
    }
}
void longer_hou() //从最后一个开始的递增子序列
{
    for(int i=n-1; i>=0; i--)
    {
        dp2[i]=1;
        for(int j=n-1; j>i; j--)
        {
            if(a[i]>a[j])
                dp2[i]=max(dp2[i],dp2[j]+1);
        }
    }
}
int main()
{

    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
            scanf("%lf",&a[i]);
        longer_qian();
        longer_hou();
        int MAX=0;
        for(int i=0; i<n; i++)
            for(int j=i+1; j<n; j++) //两层循环,避免两个递增子序列中的人重复
                MAX=max(MAX,dp1[i]+dp2[j]);
        printf("%d\n",n-MAX);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值