2016 Multi-University Training Contest 2 1009 It's All In The Mind

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5742

题目:

Problem Description
Professor Zhang has a number sequence a1,a2,...,an . However, the sequence is not complete and some elements are missing. Fortunately, Professor Zhang remembers some properties of the sequence:

1. For every i{1,2,...,n} , 0ai100 .
2. The sequence is non-increasing, i.e. a1a2...an .
3. The sum of all elements in the sequence is not zero.

Professor Zhang wants to know the maximum value of a1+a2ni=1ai among all the possible sequences.
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first contains two integers n and m (2n100,0mn) -- the length of the sequence and the number of known elements.

In the next m lines, each contains two integers xi and yi (1xin,0yi100,xi<xi+1,yiyi+1) , indicating that axi=yi .
 

Output
For each test case, output the answer as an irreducible fraction " p / q ", where p , q are integers, q>0 .
 

Sample Input
  
  
2 2 0 3 1 3 1
 

Sample Output
  
  
1/1 200/201

前两个数尽可能大,后面的数尽可能小,乱搞一下即可。

#include <iostream>
#include<cstdio>
#include<cmath>
#include<cstring>

using namespace std;

int gcd(int x,int y)
{
    return y==0?x:gcd(y,x%y);
}
int a[110];

int main()
{
    int T,n,m;
    cin>>T;
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(a,-1,sizeof(a));
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            a[x]=y;
        }
        if(a[1]==-1)
        {
            a[1]=100;
            if(a[2]==-1)    a[2]=100;
        }
        else    if(a[2]==-1)    a[2]=a[1];
        int t=0;
        for(int i=n;i>2;i--)
        {
            if(a[i]<t)  a[i]=t;
            else    t=a[i];
        }
        int x=a[1]+a[2],y=0;
        for(int i=1;i<=n;i++)   y+=a[i];
        int c=gcd(x,y);
        printf("%d/%d\n",x/c,y/c);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值