hdu 1992 Tiling a Grid With Dominoes

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1992
题目:
Problem Description
We wish to tile a grid 4 units high and N units long with rectangles (dominoes) 2 units by one unit (in either orientation). For example, the figure shows the five different ways that a grid 4 units high and 2 units wide may be tiled.



Write a program that takes as input the width, W, of the grid and outputs the number of different ways to tile a 4-by-W grid.
 

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset contains a single decimal integer, the width, W, of the grid for this problem instance.
 

Output
For each problem instance, there is one line of output: The problem instance number as a decimal integer (start counting at one), a single space and the number of tilings of a 4-by-W grid. The values of W will be chosen so the count will fit in a 32-bit integer.
 

Sample Input
   
   
3 2 3 7
 

Sample Output
   
   
1 5 2 11 3 781

找规律。
#include <iostream>
#include<cstdio>

using namespace std;

int d[23]={1,1,5,11};

int main()
{
    for(int i=4;i<23;i++)   d[i]=d[i-1]+5*d[i-2]+d[i-3]-d[i-4];
    int T;
    scanf("%d",&T);
    for(int k=1;k<=T;k++)
    {
        int n;
        scanf("%d",&n);
        printf("%d %d\n",k,d[n]);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值