Bananas are the favoured food of monkeys.
In the forest, there is a Banana Company that provides bananas from different places.
The company has two lists.
The first list records the types of bananas preferred by different monkeys, and the second one records the types of bananas from different places.
Now, the supplier wants to know, whether a monkey can accept at least one type of bananas from a place.
Remenber that, there could be more than one types of bananas from a place, and there also could be more than one types of bananas of a monkey's preference.
Input Format
The first line contains an integer T, indicating that there are T test cases.
For each test case, the first line contains two integers N and M, representing the length of the first and the second lists respectively.
In the each line of following N lines, two positive integers i,j indicate that the i-th monkey favours the j-th type of banana.
In the each line of following M lines, two positive integers j,k indicate that the j-th type of banana could be find in the k-th place.
All integers of the input are less than or equal to 50.
Output Format
For each test case, output all the pairs x,y that the x-the monkey can accept at least one type of bananas from the y-th place.
These pairs should be outputted as ascending order. That is say that a pair of x,y which owns a smaller xshould be output first.
If two pairs own the same x, output the one who has a smaller y first.
And there should be an empty line after each test case.
样例输入
1 6 4 1 1 1 2 2 1 2 3 3 3 4 1 1 1 1 3 2 2 3 3
样例输出
1 1 1 2 1 3 2 1 2 3 3 3 4 1 4 3
题意:
有若干只猴子喜欢若干种香蕉,每一种类的香蕉可以来自若干产地,问每只猴子能吃到自己喜欢香蕉种类有哪些,并打印出来
思路:
直接暴力
//
// main.cpp
// A
//
// Created by zc on 2017/9/14.
// Copyright © 2017年 zc. All rights reserved.
//
#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
using namespace std;
const int N=110;
int a[N][N],b[N][N],c[N][N];
int main(int argc, const char * argv[]) {
int T,n,m,x,y;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
for(int i=0;i<n;i++)
{
scanf("%d%d",&x,&y);
a[x][y]=1;
}
for(int i=0;i<m;i++)
{
scanf("%d%d",&x,&y);
b[x][y]=1;
}
for(int k=0;k<=50;k++)
for(int i=0;i<=50;i++)
for(int j=0;j<=50;j++)
c[i][j]|=a[i][k]*b[k][j];
for(int i=0;i<=50;i++)
for(int j=0;j<=50;j++)
if(c[i][j])
{
printf("%d %d\n",i,j);
}
printf("\n");
}
}