【2017西安网络赛】C Sum

Define the function S(x)S(x) for xx is a positive integer. S(x)S(x) equals to the sum of all digit of the decimal expression of xx. Please find a positive integer kk that S(k∗x)%233=0S(kx)%233=0.

Input Format

First line an integer TT, indicates the number of test cases (T≤100T100). Then Each line has a single integer x(1≤x≤1000000)x(1x1000000) indicates i-th test case.

Output Format

For each test case, print an integer in a single line indicates the answer. The length of the answer should not exceed 20002000. If there are more than one answer, output anyone is ok.

样例输入
1
1
样例输出
89999999999999999999999999

题意:
有一个函数S(x)的值是一个数的十进制表示,所有位数之和。 现在S(k*x)%233=0;问你K的值是多少。
思路:
因为说了长度小于2000,最大的数为1000000,长度为7,7*233<2000,所以不管输入,直接输出233个1000000。

//
//  main.cpp
//  C
//
//  Created by zc on 2017/9/16.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int main(int argc, const char * argv[]) {
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<233;i++)    printf("1000000");
        printf("\n");
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值