POJ 3278 广度搜索 一个终点

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 66244 Accepted: 20811

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


遇到的问题和思路:

       刚开始看这道题目的时候,第一反应就是深度搜索,然后仔细看了一下并没有发觉如何搜索,因为深度搜索是分顺序的,很难描述(或许有些大神会,这里不要吐槽我哦)。然后就想到了广度搜索,用队列。然后到广搜的时候又碰到了问题,因为看了一下别人的思路和我一样,然而我TLE ,别人是AC,就是因为别人在push到队列里去的时候if中多了一个条件,然而我很不解为什么要多这一个条件,后来岂不是可能也走到这个位置吗。然后想了一想,确实,如果之前能走到这个位置呢,那么用的时间肯定比后来访问到的要短,那么还要后来访问到的干什么呢。(这就是一种优化)



给出代码:


#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#define inf 1000000000

using namespace std;

int n, k;
int map[100005];
//typedef pair<int, int> P;
queue <int> que;


int bfs(){
	que.push(n);
	while(que.size()){
		int x = que.front();
		que.pop();
		if(x == k)break;
		if(x > k){
			que.push(x - 1);
			map[x - 1] = min(map[x - 1], map[x] + 1);
			continue;
		}
		if(x > 0 && x <= 100000 && map[x - 1] == inf){
			que.push(x - 1);
			map[x - 1] = min(map[x] + 1, map[x - 1]);
		}
		if(x >= 0 && x < 100000 && map[x + 1] == inf){
			que.push(x + 1);
			map[x + 1] = min(map[x + 1], map[x] + 1);
		}
		if(x <= 50000 && x > 0 && map[x * 2] == inf){
			que.push(x * 2);
			map[x * 2] = min(map[x * 2], map[x] + 1);
		}
	}
	//printf("%d\n", map[k]);
	return 0;
}

void solve(){
	
    bfs();
	printf("%d\n", map[k]);
}

int main(){
	while(scanf("%d%d",&n,&k)!=EOF){
		for(int i = 0;i <= 100003; i++)map[i] = inf;
		map[n] = 0;
		solve();
	}	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值