HDU1863 并查集与最小生成树

畅通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22804    Accepted Submission(s): 9899


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
 

Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
 

Sample Input
  
  
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
 

Sample Output
  
  
3 ?

与1233相似。就是多了一个tally的判断。


给出AC代码:


prim算法:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>

using namespace std;

const int MAX_N = 120 + 10;
const int inf = 0x3f3f3f3f;
long long n, m, a, b, v;
long long cost[MAX_N][MAX_N];
bool used[MAX_N];
long long mincost[MAX_N];


long long prim(){
    mincost[0] = 0;
    long long res = 0, tally = 0;
    while(true){
        int v = -1;
        for(int i = 0; i < m; i++){//选出当前,价值最小的边所连接的顶点 
            if (!used[i] && (v == -1 || mincost[i] < mincost[v]))v = i;
        }
        if(mincost[v] == inf || v == -1)break;
        tally++;
        used[v] = true;
        res += mincost[v];
        for(int i = 0; i < m; i++){
            mincost[i] = min (mincost[i], cost[v][i]);//v所连接的边中的最小的值 
        }    
    }
    //printf("%d\n", tally);
    if(tally == m)printf("%I64d\n", res);
    else printf("?\n");
    return 0;
}
void inti(){
    for(int i = 0; i < MAX_N; i++){
        for(int j = 0; j < MAX_N; j++){
            cost[i][j] = inf;
        }
    }
}

int main(){
    while(scanf("%I64d%I64d", &n, &m) && n){
        inti();
        memset(used, 0, sizeof(used));
        fill(mincost, mincost + MAX_N, inf);
        for(int i = 0; i < n; i++){
            scanf("%I64d%I64d%I64d", &a, &b, &v);
            cost[a-1][b-1] = v;
            cost[b-1][a-1] = v;
        }
        prim();
        //printf("%I64d\n", prim());
    }
    return 0;
}



kruskal算法


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>

using namespace std;

typedef long long ll;
const ll MAX_N = 100 + 20;
ll n, m, par[MAX_N + 10], rank1[MAX_N + 10];
struct edge{
    ll from, to, cost;
};
edge es[MAX_N * MAX_N + 10];

bool cmp(const edge &e1, const edge &e2){
    return e1.cost < e2.cost;
}

void init(){
    for(int i = 1; i <= n; i++){
        par[i] = i;
        rank1[i] = 0;
    }
}

int find(int x){
    if(par[x] == x) return x;
    return par[x] = find(par[x]);
}

void unite(int x, int y){
    x = find(x);
    y = find(y);
    if(x == y)return ;
    if(rank1[x] > rank1[y]){
        par[y] = x;
    }
    else {
        par[x] = y;
        if(rank1[x] == rank1[y])rank1[y]++;
    }
}


bool same(int a, int b){
    return find(a) == find(b);
}

void kruskal(){
    sort(es + 1, es + n + 1, cmp);
    init();
    ll res = 0 , tally = 0;
    for(int i = 1; i <= n; i++){
        edge e = es[i];
        if(!same(e.from, e.to)){
            unite(e.from, e.to);
            res += e.cost;
            tally++;
        }
    }
    
    if(tally == m-1)printf("%I64d\n", res);
    else printf("?\n");
}

int main(){
    while(scanf("%I64d%I64d", &n, &m) && n){
        //f = n * (n - 1) / 2;
        for(int i = 1; i <= n; i++){
            scanf("%I64d%I64d%I64d", &es[i].from, &es[i].to, &es[i].cost);
        }
        kruskal();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值