ZCMU-1800-Demerit Points

1800: Problem D: Demerit Points

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 4   Solved: 3
[ Submit][ Status][ Web Board]

Description

Problem D: Demerit Points

A province to our west, which shall remain nameless, but whose name does not start with A, B, or S, has a unique system for driver's license demerit and merit points. The system works (more or less) as follows.

A new driver starts with no merit or demerit points. When the driver is convicted of a driving offense, he or she is given between 2 and 15 demerit points, depending on the severity of the offense.

A merit point is given, to a maximum of five, for each interval of two years in which a driver has no offenses and no demerit points. Each merit point cancels up to two demerit points. If a subsequent offense occurs and the number of demerit points exceeds double the number of merit points, the number of demerit points is reduced by double the number of merit points, and the number of merit points is set to 0. If a subsequent offense occurs and the number of demerit points is less than or equal to double the number of merit points, the number of demerit points is reduced to 0, and the number of merit points is reduced by half the number of demerit points. Any fractional merit points are discarded.

Demerit points are reduced whenever a driver has one year free of any driving offense. This reduction decreases the number of demerits by half or by 2, whichever is more. Any fractional or negative demerit points are discarded. This reduction takes place on each anniversary of the most recent offense until no points remain.

If a new offense occurs on the same day as a demerit point reduction or merit point award, the reduction/award is done before the new demerit points are given.

Your job is to read a set of information records for a driver, and to print the number of merit or demerit points at any given time.

The first line of input contains the date of issue of the license (yyyymmdd) Subsequent lines contain information on offenses, in chronological order. Each such line contains the offense date (yyyymmdd) and the number of points applied (an integer between 2 and 15). On the day the license is issued, and on every occasion that the number of merit or demerit points changes, output a line giving the date and the number of points, in the format below. Output terminates when 5 merit points are accumulated following the last offense.

Input

Output

Sample Input

19820508
19830606 2
19830607 2
19891212 15

Sample Output

1982-05-08 No merit or demerit points.
1983-06-06 2 demerit point(s).
1983-06-07 4 demerit point(s).
1984-06-07 2 demerit point(s).
1985-06-07 No merit or demerit points.
1987-06-07 1 merit point(s).
1989-06-07 2 merit point(s).
1989-12-12 11 demerit point(s).
1990-12-12 5 demerit point(s).
1991-12-12 2 demerit point(s).
1992-12-12 No merit or demerit points.
1994-12-12 1 merit point(s).
1996-12-12 2 merit point(s).
1998-12-12 3 merit point(s).
2000-12-12 4 merit point(s).
2002-12-12 5 merit point(s).
【解析】
这道题就是给你一个起始时间,再给你其他时间和扣的分,如果在一年当中没有扣分的话,就让扣的分减去max(2,demerit/2)
如果扣的 分为0,那就让merit加1,merit可以抵2分,比如说拥有两个merit,而扣了15分,这个时候分数一抵就变成了11分了
如果最后输入的还是扣分的,只要有merit并且还扣的分就要用merit来抵消就算是只扣1分也要抵消,或者,merit不到5就每
两年输出一次。merit加上1.在输入结束的时候merit都要置0,从0开始。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
int year,month,day,mer,demer;
void facs(int n)
{
   year=n/10000;//计算年份月份日子
   n%=10000;
   month=n/100;
   day=n%100;
}
int main()
{
    int n,m,k;
    scanf("%d",&n);
    k=n;
    facs(k);
     printf("%04d-%02d-%02d No merit or demerit points.\n",year,month,day);//先输出最开始的
    while(~scanf("%d%d",&n,&m))
    {
        int count1=0;
        for(k+=10000;k<=n;k+=10000)//从K日期开始到n结束
        {
            if(demer>0)
            {
                demer-=max(2,int(demer+1)/2);//
                facs(k);
                if (demer>0) printf("%04d-%02d-%02d %d demerit point(s).\n",year,month,day,demer);
                else
                {
                    demer=0;
                    printf("%04d-%02d-%02d No merit or demerit points.\n",year,month,day);
                }
            }
            else
            {
                if (count1%2!=0)//count1从0开始,变成1的时候代表已经第二年是demerit为0了
                {
                    mer++;
                    facs(k);
                    printf("%04d-%02d-%02d %d merit point(s).\n",year,month,day,mer);
                }
                count1++;
            }
        }
            k=n;
            demer+=m;
            facs(k);
            if (mer)//如果merit不为零就可以抵消demerit
           {
            while (demer>0 && mer>0)
                mer--,demer-=2;//并且要清空merit为0
            mer=0;
           }
        if (mer>0)
            printf("%04d-%02d-%02d %d merit point(s).\n",year,month,day,mer);
        if (demer>0)
            printf("%04d-%02d-%02d %d demerit point(s).\n",year,month,day,demer);
        if (demer==0 && mer==0)
            printf("%04d-%02d-%02d No merit or demerit points.\n",year,month,day);
    }
    while (demer!=0)
    {
        k+=10000;
        facs(k);
        demer-=max(2,(int)((demer+1)/2));
        if (demer>0) printf("%04d-%02d-%02d %d demerit point(s).\n",year,month,day,demer);
        else
        {
            demer=0;
            printf("%04d-%02d-%02d No merit or demerit points.\n",year,month,day);
        }
    }
    for (mer=0;mer<6;mer++)//从0开始
    if (mer)
    {
        k+=20000;
        facs(k);
        printf("%04d-%02d-%02d %d merit point(s).\n",year,month,day,mer);
    }
    return 0;
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值