易语言组合框去重复到列表框

在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。

.版本 2
.支持库 spec
.支持库 EDataStructure

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 项目, 文本型

项目 = 组合框1.内容
.判断开始断 (列表框加入项目 (列表框1, 项目) = 1)
    ' 信息框 (“项目存在了”, 0, , )
.默认
    ' 列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    ' 组合框1.现行选中项 = 0
.判断结束
调试输出 (组合框1.取项目文本 (组合框1.现行选中项))
.如果 (查找列表框文本 (列表框1, 项目) = 真)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
.否则

.如果结束


.子程序 列表框加入项目, 逻辑型, , 不重复加入
.参数 列表框, 列表框
.参数 欲加入的项目文本, 文本型
.局部变量 i, 整数型

.计次循环首 (列表框.取项目数 (), i)
    .如果真 (欲加入的项目文本 = 列表框.取项目文本 (i - 1))
        返回 (假)
    .如果真结束

.计次循环尾 ()
列表框.加入项目 (欲加入的项目文本, )
返回 (真)

.子程序 去重复, 文本型
.参数 文本数组, 文本型, 数组
.局部变量 i, 整数型
.局部变量 分割数组, 文本型, , "0"
.局部变量 内容数组, 文本型, , "0"
.局部变量 n, 整数型
.局部变量 去重复, 节点
.局部变量 内容, 文本型

.计次循环首 (取数组成员数 (文本数组), i)
    分割数组 = 分割文本 (文本数组 , “*”, )
    .如果真 (取数组成员数 (分割数组) > 2)
        加入成员 (内容数组, 分割数组 [2])

    .如果真结束

.计次循环尾 ()
.计次循环首 (取数组成员数 (内容数组), n)
    .如果真 (去重复.加入属性 (内容数组 [n], 真))
        内容 = 内容 + 文本数组 [n] + #换行符
    .如果真结束

.计次循环尾 ()
返回 (内容)

.子程序 _按钮2_被单击, , , 输出列表框旋转项目
.局部变量 a, 整数型

.计次循环首 (列表框1.取项目数 (), a)
    .如果真 (列表框1.是否被选择 (a - 1))
        调试输出 (列表框1.取项目文本 (a - 1))
    .如果真结束

.计次循环尾 ()

.子程序 子程序_组合框加入项目, 逻辑型, , 重复返回假
.参数 组合框, 组合框
.参数 欲加入的项目文本, 文本型
.局部变量 i, 整数型

.计次循环首 (组合框.取项目数 (), i)
    .如果真 (欲加入的项目文本 = 组合框.取项目文本 (i - 1))
        返回 (假)
    .如果真结束

.计次循环尾 ()
组合框.加入项目 (欲加入的项目文本, )
返回 (真)

.子程序 查找列表框文本, 逻辑型, , 查找列表框里的文本是否存在
.参数 列表框, 列表框
.参数 欲加入的项目文本, 文本型
.局部变量 i, 整数型

.计次循环首 (列表框.取项目数 (), i)
    .如果真 (欲加入的项目文本 = 列表框.取项目文本 (i - 1))
        返回 (假)
    .如果真结束

.计次循环尾 ()
' 列表框.加入项目 (欲加入的项目文本, )
返回 (真)

.子程序 _按钮3_被单击, , , 方法2
.局部变量 项目, 文本型

项目 = 组合框1.内容
列表框加入项目 (列表框1, 项目)

.子程序 _按钮4_被单击

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值