易语言列表框防止项目重复加入列表框

本节视频通过三种方法实现了防止项目重复加入列表框。

易语言列表框防止项目重复加入列表框视频教程源码:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

列表框1.现行选中项 = 0
皮肤_加载 (1)

.子程序 _按钮1_被单击

列表框1.加入项目 (编辑框1.内容, )
编辑框1.内容 = “”

.子程序 _按钮2_被单击, , , 不重复加入-1

.如果 (列表框1.选择 (编辑框1.内容) = -1)
列表框1.加入项目 (编辑框1.内容, )
信息框 (“添加成功!”, 0, , )
.否则
信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )

.如果结束

.子程序 _按钮3_被单击, , , 不重复加入-2

.如果 (SendMessageA (列表框1.取窗口句柄 (), 399, 0, 编辑框1.内容) = -1)
列表框1.加入项目 (编辑框1.内容, )
信息框 (“添加成功!”, 0, , )
.否则
信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )

.如果结束

.子程序 _按钮4_被单击, , , 不重复加入-3
.局部变量 i, 整数型
.局部变量 重复, 逻辑型

.计次循环首 (列表框1.取项目数 (), i)
.如果真 (列表框1.取项目文本 (i - 1) = 编辑框1.内容)
重复 = 真
跳出循环 ()
.如果真结束
重复 = 假
.计次循环尾 ()

.如果 (重复 = 假)
列表框1.加入项目 (编辑框1.内容, )
编辑框1.内容 = “”
信息框 (“添加成功!”, 0, , )
.否则
信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 16, , )
.如果结束

源码:511遇见易语言教程

           511遇见易语言教程视频链接

           易语言列表框防止项目重复加入列表框

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

511遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值