3.24 H

Given a permutation a1, a2, … aN of {1, 2, …, N}, we define its E-value as the amount of elements where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1} is 2. You are requested to find how many permutations of {1, 2, …, N} whose E-value is exactly k.
Input
There are several test cases, and one line for each case, which contains two integers, N and k. (1 <= N <= 1000, 0 <= k <= N).
Output
Output one line for each case. For the answer may be quite huge, you need to output the answer module 1,000,000,007.
Sample Input
3 0
3 1
Sample Output
1
4

Hint
There is only one permutation with E-value 0: {1,2,3}, and there are four permutations with E-value 1: {1,3,2}, {2,1,3}, {3,1,2}, {3,2,1}

dp[i][j]表示i个数,E的值为j的组合数。
i=i-1时再加一个数前有两种情况,j=j-1和j=j。
j=j-1时,只需要让新加的数和a[i]<i的(i-j)个数交换,有(i-j)种可能。
j=j时,可以直接加在最后或者和a[i]>i的j个数交换,有j+1中可能.
dp[i][j]=(dp[i-1][j](j+1)%mod+dp[i-1][j-1](i-j)%mod)%mod

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const long long mod=1000000007;
long long dp[1001][1001];
int main()
{
    int n,k;
    int i,j;
    for(i=1;i<=1000;i++)
    {
        dp[i][0]=1;
        for(j=1;j<i;j++)
        {
            dp[i][j]=(dp[i-1][j-1]*(i-j)%mod+dp[i-1][j]*(j+1)%mod)%mod;
        }
    }
    while(cin>>n>>k)
    {
        cout<<dp[n][k]<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值