3.25 H

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7
离谱,最难的地方我觉得是如何保存和输出那组最优解。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#define INF 0x3f3f3f3f
using namespace std;
const int N=1005;
struct f
{
    int w,v,id;
}a[1009];
bool cmp(f a,f b)
{

	if(a.w==b.w) return a.v<b.v;
    return a.w<b.w;
}
int dp[1009],c[1009];
int main()
{
    int t=1,x,y,i,j;
    while(cin>>x>>y)
    {
        a[t].w=x;
        a[t].v=y;
        a[t].id=t;
        dp[t]=1;
        t++;
    }
    dp[1]=1;
    sort(a+1,a+t,cmp);
    int maxx=1;
    for(i=2;i<t;i++)
    {
        for(j=1;j<i;j++)
        {
            if(a[i].w>a[j].w&&a[i].v<a[j].v)
            {
                dp[i]=max(dp[i],dp[j]+1);
                if(dp[i]>dp[maxx])
                    maxx=i;
            }
        }
    }
    cout<<dp[maxx]<<endl;
    int temp=maxx;
	vector<int>G;
	G.push_back(maxx);
    for(i=maxx-1;i>=1;i--)
    {
        if(dp[i]+1==dp[maxx])
        {
			G.push_back(i);
            maxx=i;
        }
    }
    for(i=dp[temp]-1;i>=0;i--)
        cout<<a[G[i]].id<<endl;
}

在C语言中,我们可以使用两种数据结构——链表(Linked Lists)和数组(Arrays)来实现队列(Queue)。以下是各自的实现方法: **a. 队列使用链表实现(Linked List)** ```c #include <stdio.h> #include <stdlib.h> // 定义链表节点结构体 typedef struct Node { int data; struct Node* next; } QueueNode; // 创建一个空队列 QueueNode* createQueue() { return NULL; } // 在队列尾部添加元素 void enqueue(QueueNode** head, int value) { QueueNode* newNode = (QueueNode*)malloc(sizeof(QueueNode)); newNode->data = value; newNode->next = *head; *head = newNode; } // 从队列头部移除并返回元素 int dequeue(QueueNode** head) { if (*head == NULL) { printf("Queue is empty.\n"); return -1; } int value = (*head)->data; QueueNode* temp = *head; *head = (*head)->next; free(temp); return value; } // 主函数演示使用 int main() { QueueNode* queue = createQueue(); // 添加元素... // 删除元素... return 0; } ``` **b. 队列使用数组实现(Array)** ```c #include <stdio.h> #define MAX_SIZE 10 // 结构化数组表示队列 typedef struct { int items[MAX_SIZE]; int front; // 标记队首 int rear; // 标记队尾 } QueueArray; // 初始化一个空队列 QueueArray initQueue() { QueueArray q = { .front = -1, .rear = -1 }; return q; } // 在队尾添加元素 void enqueue(QueueArray* q, int value) { if (q->rear + 1 == MAX_SIZE) { printf("Queue is full.\n"); return; } q->items[++q->rear] = value; if (q->front == -1) q->front = 0; } // 从队首移除并返回元素 int dequeue(QueueArray* q) { if (q->front == q->rear) { printf("Queue is empty.\n"); return -1; } int value = q->items[q->front++]; return value; } // 主函数演示使用 int main() { QueueArray queue = initQueue(); // 添加元素... // 删除元素... return 0; } ``` 注意:数组队列通常用于固定大小的情况,如果需要动态扩容,可以考虑使用动态内存分配。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值