Collecting Bugs POJ - 2096(基础概率dp+期望模板)

题意:


有s个系统,n种bug,小明每天找出一个bug,可能是任意一个系统的,可能是任意一种bug,即是某一系统的bug概率是1/s,是某一种bug概率是1/n。 求他找到s个系统的bug,n种bug,需要的天数的期望。~~题意很难懂··真的很难懂···~~

 

题目:


Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.


Input


Input file contains two integer numbers, n and s (0 < n, s <= 1 000).


Output


Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

 

Sample Input


1 2

 

Sample Output


3.0000 


分析:


基础的概率dp。
令f[i][j]为当前已经找出i种bug,j个系统的,要到达目标状态(n,s)的期望天数。显然f[n][s]=0;,因为已经达到目标了。而dp[0][0]就是我们要求的答案。
考虑一下状态的转移根据题意,每个dp[i][j] 之后可以达到的状态有四种。
1.转移到[i+1][j]的概率为(n-i)/n* j/s
2.转移到[i][j+1]的概率为i/n*(s-j)/s
3.转移到[i+1][j+1]的概率为(n-i)/n*(s-j)/s
4.转移到[i][j]的概率为i/n*j/s
f[i][j]=(n-i)/n*j/s*f[i+1][j]+i/n*(s-j)/s*f[i][j+1]+f[i+1][j+1]*(n-i)/n*(s-j)/s+f[i][j]*i/n*j/s
移一下项
(1-i/n*j/s)*f[i][j]=(n-i)/n*j/s*f[i+1][j]+i/n*(s-j)/s*f[i][j+1]+f[i+1][j+1]*(n-i)/n*(s-j)/s
然后把左边的除过去得
f[i][j]=((n-i)/n*j/s*f[i+1][j]+i/n*(s-j)/s*f[i][j+1]+f[i+1][j+1]*(n-i)/n*(s-j)/s)/(1-i/n*j/s)
然后整理一下得
f[i][j]=(f[i+1][j]*(n-i)*j+f[i][j+1]*(s-j)*i+f[i+1][j+1]*(n-i)*(s-j)+n*s)/(n*s-i*j);


AC代码

 

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int M=1000+100;
double f[M][M];
int n,s;
int main()
{
    while(~scanf("%d%d",&n,&s))
    {
        memset(f,0,sizeof(f));
        for(int i=n; i>=0; i--)
            for(int j=s; j>=0; j--)
            {
                if(i==n&&j==s)
                    continue;
                f[i][j]=(f[i+1][j]*(n-i)*j+f[i][j+1]*(s-j)*i+f[i+1][j+1]*(n-i)*(s-j)+n*s)/(n*s-i*j);
            }
        printf("%.4f\n",f[0][0]);
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值