FatMouse and Cheese HDU - 1078(记忆化搜索入门模板)

题意:

n * n的正方形格子(每个格子均放了奶酪),老鼠从(0,0)开始,每次最多移动k步,可以选择上下左右四个方向移动,下一个移动点奶酪块数量必须要大于当前点。

整理模板ing…

题目:

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

分析:

记忆化搜索入门,当采用记忆化搜索时,不必事先确定各状态的计算顺序,但需要记录每个状态“是否已经计算过”。
总结一下记忆化搜索是啥:
1.不依赖任何 外部变量(调用函数内的变量也没有变化)
2.答案以返回值的形式存在, 而不能以参数的形式存在(就是不能将 dfs 定义成 dfs(pos ,tleft , nowans ) , 这里面的 nowans 不符合要求).
3.对于相同一组参数, dfs 返回值总是相同的(参见第一条)
就这道题复杂度为:O( n 2 n^{2} n2):每个点只遍历了一次,从O( 2 n 2^{n} 2n)~O( n 2 n^{2} n2)这是记忆化搜索算法在时间复杂度上的优越性

AC代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int dp[110][110],a[110][110];
int c[4][2]= {0,1,0,-1,1,0,-1,0};
int dfs(int u,int v)
{
    if(dp[u][v]!=-1)
        return dp[u][v];
    dp[u][v]=a[u][v];
    for(int i=0; i<4; i++)
        for(int j=1; j<=m; j++)
        {
            int x=u+c[i][0]*j;
            int y=v+c[i][1]*j;
            if(x<0||y<0||x>=n||y>=n||a[u][v]>=a[x][y])
                continue;
            dp[u][v]=max(dp[u][v],dfs(x,y)+a[u][v]);
        }
    return  dp[u][v];
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1)
            break;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&a[i][j]);
        memset(dp,-1,sizeof(dp));
        printf("%d\n",dfs(0,0));
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值