ROADS POJ - 1724(最短路+邻接表+dfs)

题意:

N个城市,编号1到N。城市间有R条单向道路。有长度和过路费两个属性。Bob只有K块钱,他想从城市1走到城市N。问最短共需要走多长的路。如果到不了N,输出-1。

题目:

N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

分析:

给了n个城市,需要从城市1到城市n,求最短距离,要是这样就是一道简单的最短路问题,但题目有限制要求,在满足花费即不超过k的情况下的最短路
1.首先考虑得用搜索,迭代寻找,在找到所有满足路径后,选出最短的(注意剪枝)。
2.选用邻接表来存储无向图的时间空间复杂度是O(M)。
如果只是查询两个点之间是否相邻,邻接矩阵当然更快,但如果是做dfs的话,找当前节点相邻的点,如果用邻接矩阵的话每次都要从1扫到n,如果用邻接表遍历每个顶点的边

AC代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int M=1e4+10;
int n,m,k;
ll ans;
int a[M],b[M],c[M],d[M],fir[M],nex[M],book[M];
void dfs(int x/*当前到达城市*/,int y/*费用*/,int z/*路程*/)
{
    if(y>n||z>=ans)
        return ;
    if(x==m)
    {
        ans=z;
        return ;
    }
    for(int i=fir[x];i;i=nex[i])
     if(!book[i])
     {
         book[i]=1;
         dfs(b[i],y+d[i],z+c[i]);
         book[i]=0;
     }
     return ;
}
int main()
{
    scanf("%d%d%d",&n,&m,&k);
    for(int i=1;i<=k;i++)/*care 变量要从1开始,邻接表定义*/
    {
        scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
        nex[i]=fir[a[i]];
        fir[a[i]]=i;
    }
    ans=inf;
    dfs(1,0,0);
    if(ans==inf) printf("-1\n");
    else printf("%lld\n",ans);
    return 0;               
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值