题意:
给定一个数组和一个值t,求一个子区间使得其和的绝对值与t的差值最小,如果存在多个,任意解都可行。
题目:
Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.
You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15
分析:
1、 什么情况下能使用尺取法?
尺取法通常适用于选取区间有一定规律,或者说所选取的区间有一定的变化趋势的情况,通俗地说,在对所选取区间进行判断之后,我们可以明确如何进一步有方向地推进区间端点以求解满足条件的区间,如果已经判断了目前所选取的区间,但却无法确定所要求解的区间如何进一步得到根据其端点得到,那么尺取法便是不可行的。。首先,明确题目所需要求解的量之后,区间左右端点一般从最整个数组的起点开始,之后判断区间是否符合条件在根据实际情况变化区间的端点求解答案。
(1)我在补挑战程序设计,所以明确知道这道题使用尺取法,但我对于 问题分析后,完全没看出来选取区间有啥规律(由于题目是求一个子区间使得其和的绝对值与t的差值最小,如果存在多个,任意解都可行。存在负数)所以对于区间端点的推进是无法正常进行的。
(2)对前缀和sum排序。然后这时候的sum就有单调性了,根据每次两个区间端点作差的值与目标值比较,对端点尝试更新。
(3)原问题就转化为了在一个升序区间中,取两个区间端点作差,求最接近 s 的值。
(4)需要care:
1、当左右端点相等时,此时为前缀和,没有意义且不可能出现,导致错误,所以我们要排除。
2、sort排序要带上起始的初始化零点,一是答案可能导致错误,二一个我们是用前缀和进行比较,所以不可或缺。
AC模板:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int M=1e5+10;
int n,m,k,l,r,x,y,ans,mi;
struct node
{
int id,sum;
}s[M];
bool cmp(node x,node y)
{
return x.sum<y.sum;
}
void solve()
{
l=0,r=1,mi=inf;
while(l<=n&&r<=n&&mi!=0)
{
int temp=s[r].sum-s[l].sum;
if(abs(temp-k)<mi)
{
mi=abs(temp-k);
x=s[l].id;
y=s[r].id;
ans=temp;
}
if(temp>k) l++;
else if(temp<k) r++;
else break;
if(r==l) r++;
}
if(x>y) swap(x,y);
printf("%d %d %d\n",ans,x+1,y);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0)
break;
s[0].sum=s[0].id=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&s[i].sum);
s[i].sum+=s[i-1].sum;
s[i].id=i;
}
sort(s,s+1+n,cmp);/**要带上0项*/
while(m--)
{
scanf("%d",&k);
solve();
}
}
return 0;
}