Coins POJ - 1742(多重背包+是否装满问题)

题意:

给定n种面值的硬币面值分别为 W i W_{i} Wi个数为 C i C_{i} Ci,问用这些硬币可以组成1~m之间的多少面值。

题目:

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

分析:

1.关于是否装满问题,其实之前的博客讨论过这个问题,但只需考虑装满问题时,就可以考虑情况,“标记当前出现状况”的形式来计算装满问题。
2.定义一个sum数组。每次填dp[j]时直接由dp[j-a[i]]推出,前提是sum[j-a[i]]<b[i]。sum每填一行都要清零,sum[j]表示当前物品填充j大小的包需要至少使用多少个。复杂度O(n*m)。

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int M=1e5+10;
int n,m,ans;
int a[M],b[M],num[M],dp[M];
int main(){
    while(~scanf("%d%d",&n,&m)){
        if(n==0&&m==0)
            break;
        ans=0;
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&b[i]);
        for(int i=0;i<n;i++){
            memset(num,0,sizeof(num));
            for(int j=a[i];j<=m;j++){
                if(!dp[j]&&dp[j-a[i]]&&num[j-a[i]]<b[i]){
                    dp[j]=1;
                    ans++;
                    num[j]=num[j-a[i]]+1;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值