二分+最大化最小值 River Hopscotch POJ - 3258

题意:

起始有两个石头,位置是 0 0 0 n n n,在这中间有n个石头,问如何拿走m块石头后,使得他们之间的最小间隔的最大值。

题目:

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2…N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

分析:

由于是求最小间隔的最大值,(起初我理解成求出最大间隔,那么直接连续拿,遍历一遍就好,那肯定是错的),那么如何处理每次拿走石头都有可能改变之间间隔的最小值呢?
1.首先考虑到,只要拿走石头都会使石头之间的间隔变大,那么我们只需要枚举最小的间隔,看是否满足拿走k个石头后,仍旧是最小间隔。
2.那么如何求的最大的最小间隔呢,我们用二分进行枚举最小间隔即可
3.对石头位置进行排序,为之后的遍历寻找去掉一个石头后计算之间的间隔做准备。
4. d f s ( x ) = x dfs(x)=x dfs(x)=x是所有石头间的最小间隔,即任意两个石头之间的间隔都不能小于 x x x,我们可以拿走k块石头,那就判断,当拿走k块石头后,仍是最小间隔即可。当存在拿走大于等于k个石头后,仍旧是最小间隔时,说明此时最小间隔偏大(我们最终需要的是正好拿走k个石头,使得该枚举的最小间隔,是石头间的最小间隔)

AC代码:

#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int M=5e4+10;
int n,m,k;
int f[M];
bool dfs(int x){///假设x是所有石头间的最大最小间隔,则此时需要判断拿走k个石头后,是否仍是最小间隔。
    int num=0;
    for(int i=1;i<m-k;i++){///一共m-2-k次循环,哪怕不满足while循环pre=m-k
        int pre=num+1;
        while(pre<m&&f[pre]-f[num]<x){///当存在石头间隔小于最小间隔,拿走这个石头,使间隔变大
            pre++;
        }
        if(pre==m){///若假设成立,存在拿走>=k块石头让石头间隔小于最小间隔;
            return false;
        }
        num=pre;
    }
    return true;
}
int main(){
    cin>>n>>m>>k;
    f[0]=0;
    for(int i=1;i<=m;i++){
        cin>>f[i];
    }
    f[m+1]=n;
    m=m+2;
    sort(f,f+m);
    int r=0,l=n+1;//上界要稍大一些,否则mid永远取不到值n
    while(l-r>1){
        int mid=(r+l)>>1;
        if(dfs(mid))//说明此时枚举的间隔较小
            r=mid;
        else l=mid;//是否可能使得所有石头之间的距离不小于d
    }
    cout<<r<<endl;
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值