Largest Rectangle in a Histogram (动态规划+奇思妙想单调栈)求最大矩状图面积

感觉动态规划都是玄妙的很,思维题吧(单调栈思维)

题解:让求最大矩形面积,宽为1,暴力超时

可以发现   当第i-1个比第i个高的时候   比第i-1个高的所有也一定比第i个高  

于是可以用到动态规划的思想

令left[i]表示包括i在内比i高的连续序列中最左边一个的编号   right[i] 为最右边一个的编号

那么有   当 h[left[i]-1]>=h[i]]时   left[i]=left[left[i]-1]  从前往后可以递推出left[i]   

同理      当 h[right[i]+1]>=h[i]]时   right[i]=right[right[i]+1]   从后往前可递推出righ[i]

最后答案就等于  max((right[i]-left[i]+1)*h[i]) 了;

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000
/*题目题意:题目给了n个矩形的高度,问最大连续矩形的公共面积(底乘以这段连续矩形中
最短的高度),每个矩形的底是1
题目分析:我们可以枚举每一个矩形,把它当作最矮的矩形,剩下就差知道底了。
既然这个矩形是最矮的的那一个,那么它左边的矩形和右边的矩形的高度应该大于等于它!*/
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;
const int maxn=1e5+1000;
ll a[maxn],Left[maxn],Right[maxn];
int main()
{
    int n;
    while (~scanf("%d",&n)&&n)
    {
        for(int i=1; i<=n; i++)
            scanf("%lld",&a[i]);
        Left[1]=1;
        Right[n]=n;
        for (int i=2; i<=n; i++) ///求出每个矩形左端非递减连续的下标
        {
            int t=i;
            while (t>1&&a[i]<=a[t-1])/**状态转移*/
                t=Left[t-1];
            Left[i]=t;
        }
        for (int i=n-1; i>=1; i--) ///求出每个矩形右端非递减连续的下标
        {
            int t=i;
            while (t<n&&a[i]<=a[t+1])
                t=Right[t+1];
            Right[i]=t;
        }
        ll ans=0;
        for (int i=1; i<=n; i++)
            ans=max(ans,(Right[i]-Left[i]+1)*a[i]);
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值