【问题描述】
给出一个字符串,请将其每个单词反转后输出。
【输入形式】
输入第一行为一个正整数N,表示测试用例数,接下来的N行,每行一个字符串。
【输出形式】
输出N行,每行对应一个反转后的字符串。
【样例输入】
3
olleh !dlrow
m'I morf .unh
I ekil .tae
【样例输出】
hello world!
I'm from hnu.
I like eat.
#include<iostream>
#include<vector>
using namespace std;
int main()
{
int N;cin>>N;
getchar();//用getchar进行输入
for(int i=0;i<N;i++){
char a;string x;
//学会处理换行符号
while((a=getchar())!='\n'){//getchar只出一个字符;最后一个单词是读到结束所以不会输出要手动
if(a!=' ')
x.push_back(a);
else if(a==' '){
for(int k=x.size()-1;k>=0;k--)//倒序输出{
cout<<x[k];}
cout<<" ";
x.clear();}
}for(int k=x.size()-1;k>=0;k--){
cout<<x[k];}cout<<endl;
}
}