SCAU:18044 成绩等级评分

18044 成绩等级评分

时间限制:1000MS  代码长度限制:10KB
提交次数:0 通过次数:0

题型: 编程题   语言: G++;GCC;VC

Description

编写程序,由键盘输入一个百分制的整数成绩,要求输出对应的成绩等级。90分以上为A,80到89分为B,70到79分为C,60到69分为D,
60分以下为E。成绩不在0到100之间时输出“error”

输入格式

一个整数成绩

输出格式

输出对应的等级或error

输入样例

99

输出样例

A
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int score;
    scanf("%d",&score);
    if(score>=90&&score<=100)
    printf("A");
    else if(score>=80&&score<=89)
    printf("B");
    else if(score>=70&&score<=79)
    printf("C");
    else if(score>=60&&score<=69)
    printf("D");
    else if(score<60&&score>=0)
    printf("E");
    else
    printf("error");
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zero_019

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值