2 删除相关子树算法

2  删除相关子树算法

Time Limit:1000MS  Memory Limit:65535K

题型: 编程题   语言: G++;GCC

描述

构造二叉链表表示的二叉树:按先序次序输入二叉树中结点的值,'#'字符表示空树,构造二叉链表表示的二叉树T,编写算法完成:对于树中每一个值为X的结点,删
去以它为根的子树,并释放相应的空间(说明:二叉树结点值为单字符,且树中可能出现值重复的结点)。
#include "stdio.h"
#include "malloc.h"
#define TRUE 1
#define FALSE 0
#define OK  1
#define ERROR  0
#define INFEASIBLE -1
#define OVERFLOW -2
typedef int  Status;

typedef char  ElemType;
typedef struct BiTNode{
  ElemType data;
  struct BiTNode *lchild,*rchild;//左右孩子指针
} BiTNode,*BiTree;

Status CreateBiTree(BiTree &T) {  // 算法6.4
  // 按先序次序输入二叉树中结点的值(一个字符),’#’字符表示空树,
  // 构造二叉链表表示的二叉树T。
  char ch;
  scanf("%c",&ch);
  if (ch=='#') T = NULL;
  else {
    if (!(T = (BiTNode *)malloc(sizeof(BiTNode)))) return ERROR;
    ________________________ // 生成根结点
     _______________________   // 构造左子树
    _________________________  // 构造右子树
  }
  return OK;
} // CreateBiTree


int main()   //主函数
{
                      //补充代码
 }//main

输入格式

第一行输入先序次序二叉树中结点
第二行输入一个要删除的结点值

输出格式

第一行输出删除后的二叉树先序遍历的序列(不输出空树)
第二行输出删除后的二叉树中序遍历的序列(不输出空树)

输入样例

ABDCG####E##CF###
C

输出样例

ABDE
DBEA


#include "stdio.h"
#include <iostream>
#include "malloc.h"
#define TRUE 1
#define FALSE 0
#define OK  1
#define ERROR  0
#define INFEASIBLE -1
#define OVERFLOW -2
typedef int  Status;
using namespace std;

typedef char  ElemType;
typedef struct BiTNode{
  ElemType data;
  struct BiTNode *lchild,*rchild;
} BiTNode,*BiTree;

Status CreateBiTree(BiTree &T) {

  char ch;
  scanf("%c",&ch);
  if (ch=='#') T = NULL;
  else {
    if (!(T = (BiTNode *)malloc(sizeof(BiTNode)))) return ERROR;
    T->data = ch;
    CreateBiTree(T->lchild);
    CreateBiTree(T->rchild);
  }
  return OK;
}

Status p(BiTree T,char c)
{
    if(!T)return 0;
    else
    {
        if(T->data == c)
        {
            T->lchild = NULL;
            T->rchild = NULL;
        }
        else
        {
            cout<<T->data;
        }
        p(T->lchild,c);
        p(T->rchild,c);
    }
    return 1;
}

Status i(BiTree T,char c)
{
    if(!T)return 0;
    else
    {
        i(T->lchild,c);
        if(T->data == c)
        {
            T->lchild = NULL;
            T->rchild = NULL;
        }
        else
        {
            cout<< T->data;
        }
        i(T->rchild,c);
    }
    return 1;
}

int main()
{
    char c;
    BiTree T;
    CreateBiTree(T);
    cin >> c;
    p(T,c);
    cout<<endl;
    i(T,c);
    return 0;
}

  • 5
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zero_019

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值