杭电1002(大整数相加)

A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
分析:
位数太多,longlong也存储不下,用字符串来处理,重要的是如何进位,我用了一个carry中间变量来进位,如果两个同位置的数相加大于9,carry则加一,进到下一位。
代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;


int main()
{
   int t;

   scanf("%d",&t);
   char A[10000],B[10000];//存储输入数据
     int kase=0;
   while(t--)
   {
    int result[10000];
     scanf("%s%*c%s",A,B);
       int carry=0;
       int num=0;
       int len1=strlen(A)-1;
       int len2=strlen(B)-1;

       while (len1 >= 0 || len2 >= 0)//循环条件
    {
        int ch = carry;//carry是进位
        if (len1 >= 0)
        {
            if (A[len1] < '0' || A[len1] > '9')
                continue;
            ch += A[len1] - '0';
        }
        if (len2 >= 0)
        {
            if (B[len2] < '0' || B[len2] > '9')
                continue;
            ch += B[len2] - '0';
        }
        if (ch >= 10)
        {
            carry = 1;
            ch -= 10;
        }
        else carry = 0;
      result[num++]=ch;
        len1--;
        len2--;
    }
    if (carry) result[num++]=1;//如果最后大于9,前面加一

      printf("Case %d:\n",++kase);
     printf("%s + %s = ",A,B);

      for(int i=num-1;i>=0;i--)//反向输出
      printf("%d",result[i]);
      printf("\n");
      if(t!=0)
       printf("\n");

   }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值