POJ-2385

Apple Catching
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12663 Accepted: 6159

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

题意:有一头牛,两棵树,开始牛在1号树下,

每秒钟两棵树中的某一棵会掉下一颗苹果,

牛最多能在这两棵树间移动W次,

求N秒钟内牛最多能接到多少颗苹果。


代码情况:


个人理解:

/*
dp[i][j]表示在第i分钟时,已经移动了j次后得到的苹果数量。
状态转移方程:dp[i][j] = max(dp[i-1][j], dp[i-1][j-1])
对于第i秒第j次的状态,可以由两种前驱状态转移得来,
一种是i-1秒时就已经跳了j次,然后第i秒就不跳了,
另一种是i-1秒跳了j-1次,然后她还可以再跳一次得到跳j次。
即对于第i秒第j次,从它的两个可能前驱状态取最大值
加上她是否能吃到当前掉落的果子得到
然后判断当前是否在第i分钟掉苹果的那颗树下,是的话,dp[i][j]++
*/
#include<stdio.h>
# define N 1001
# define M  32
# define max(a,b) (a)>(b)?(a):(b)
int DP[N][M],S[N],i,j,m,n,F;
int main(){
    //freopen("MAM.txt","r",stdin);
    scanf("%d %d%d",&m,&n,&S[0]);
    for(i=1,DP[0][S[0]-1]=1;i<m;i++)
    {
      scanf("%d",&S[i]);
      DP[i][0]=DP[i-1][0]+S[i]%2;//对j=0的情况进行处理 此时牛没移动
    }
    for(i=1;i<m;i++)
    {
       for(j=1;j<=n;j++){
         DP[i][j]=max(DP[i-1][j-1],DP[i-1][j]);//递推公式
         if(S[i]%2!=j%2) DP[i][j]++;//如果当前苹果掉了打在这头牛上 这头牛没挂 苹果数加一
       }
       F=max(F,DP[i][n]);//牛移动了n次后的苹果最大值
    }
    printf("%d\n",max(F,DP[0][n]));
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值