poj2488(dfs)

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
#include <iostream>
#include <cstdio>
#include <string>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
int T,p,q,vis[30][30],flag;
int f[2][8]={{-2,-2,-1,-1, 1,1, 2,2},
        {-1, 1,-2, 2,-2,2,-1,1}};
struct node{
    int x;int y;
}ans[30];
bool judge(int i,int j)
{
    return i>=1&&i<=q&&j>=1&&j<=p;
}
void dfs(int x,int y,int step,int tt)
{
    if(flag) return ;
    vis [x][y]=1;
    ans[step].x=x;
    ans[step].y=y;
    if(step==p*q&&flag==0)
    {
        flag=1;
        printf("Scenario #%d:\n",tt);
        for(int i=1;i<=step;i++)
        {
            char c=ans[i].x-1+'A';
            cout << c << ans[i].y;
        }
        cout  <<endl <<endl;
        return ;
    }
    for(int i=0;i<8;i++)
    {
        int next_x=x+f[0][i];
        int next_y=y+f[1][i];
        if(judge(next_x,next_y)&&vis[next_x][next_y]!=1)
        {
            dfs(next_x,next_y,step+1,tt);
        }
    }
    vis[x][y]=0;
}
int main()
{
    scanf("%d",&T);
    for (int t=1;t<=T;t++)
    {
        memset(vis,0,sizeof(vis));
        flag=0;
        scanf("%d%d",&p,&q);
        dfs(1,1,1,t);
        if (!flag)
        {
            printf("Scenario #%d:\n",t);
            printf("impossible\n");
            printf("\n");
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值