题目
火星人是以 13 进制计数的:
地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
思路
首先判断是地球文还是火星文,根据第一个字符是否为数字确定。
然后分别转换,注意“tret”四个字符与众不同。
注意:
读入数据时,一行中可能出现空格时,需要用
getline(cin, s)
cin >> s
只能读到空格前一个单词。
getline
前有回车时(如本题中前面有cin>>n
,后跟了回车),需要加一个getchar()
吸收回车。
代码
#include <iostream>
#include <cctype>
#include <string>
using namespace std;
const string low[] = {"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
const string high[] = {"", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
int MarsToEarth(string s){
int h = 0;
int l = 0;
string hs;
string ls;
if (s.length()>4){
hs = s.substr(0, 3);
ls = s.substr(4, 3);
}
else {
hs = s;
ls = s;
}
for (int i=0; i<13; i++){
if (high[i] == hs){
h = i * 13;
break;
}
}
for (int i=0; i<13; i++){
if (low[i] == ls){
l = i;
break;
}
}
return h + l;
}
string EarthToMars(int i){
string h = high[i/13];
string l = low[i%13];
if (h!=""){
if (l=="tret"){
l = "";
}
else{
h += " ";
}
}
return h + l;
}
int main(){
int n;
cin >> n;
getchar();
string s;
for (int i=0; i<n; i++){
getline(cin , s);
if (isdigit(s[0])){
cout << EarthToMars(stoi(s)) << endl;
}
else {
cout << MarsToEarth(s) << endl;
}
}
return 0;
}