一维的01背包问题

2015年寒假集训第一次周赛的一道题:

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

 

 

#include<stdio.h>
int max(int a,int b)
{
    return a>b?a:b;
}
int w[3405],d[3405],sum[13000];           //(当时做错的原因,就是没有理解透sum这个数组是到底是记录啥的,所以数组开的不够大,导致结果是运行错 误!!)
int main()
{
    int n,m,i,j;
    scanf("%d %d",&n,&m);
    for(i=0; i<n; i++)
        scanf("%d %d",&w[i],&d[i]);
    for(i=0; i<n; i++)                        //以下三行是一维的01背包问题代码
        for(j=m; j>=w[i]; j--)
            sum[j]=max(sum[j],sum[j-w[i]]+d[i]);            //要充分理解这一行代码的意思(放与不放此时包的最大价值)
    printf("%d\n",sum[m]);
}
<span style="font-size:18px;color:#330033;">1、这是一道最基本的01背包问题,运用一维数组会比二维数组在时间复杂度上减少不少。</span>

2、而sum数组就是用来记录当体积取j时这个包内物品最大的价值。

3、所以sum这个数组要根据所允许的最大体积开内存。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值