二叉树后序遍历和层次遍历

数据结构实验之求二叉树后序遍历和层次遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

示例输入

2
abdegcf
dbgeafc
xnliu
lnixu

示例输出

dgebfca
abcdefg
linux
xnuli

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
    char a;
    struct node *l,*r;
}*tree;
char s[1010],s1[1010];
struct node *creat(struct node *root,char *s,char *s1,int n)
{
    if(n<=0) return NULL;
    root=(struct node*)malloc(sizeof(struct node));
    root->a=s[0];
    int p=strchr(s1,s[0])-s1;
    root->l=creat(root->l,s+1,s1,p);
    root->r=creat(root->r,s+p+1,s1+p+1,n-p-1);
    return root;
};
void ho(struct node *root)
{
    if(root!=NULL)
    {
        ho(root->l);
        ho(root->r);
        printf("%c",root->a);
    }
}
void ff(struct node *root)
{
    struct node *p[1010],*q;
    int be=0,end1=0;
    p[end1++]=root;
    while(be<end1){
        q=p[be++];
        printf("%c",q->a);
        if(q->l) p[end1++]=q->l;
        if(q->r) p[end1++]=q->r;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        struct node *head;
        scanf("%s",s);
        scanf("%s",s1);
        head=creat(head,s,s1,strlen(s));
        ho(head);
        printf("\n");
        ff(head);
        printf("\n");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值