数据结构实验之栈二:一般算术表达式转换成后缀式

             
B - 数据结构实验之栈二:一般算术表达式转换成后缀式
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

Input

输入一个算术表达式,以‘#’字符作为结束标志。

Output

输出该表达式转换所得到的后缀式。

Sample Input

a*b+(c-d/e)*f#

Sample Output

ab*cde/-f*+

Hint

 

#include <stdio.h>
#include <string.h>
char stack[10000];
int top;
int ch(char c)                //此函数分出来符号的等级
{
    if(c=='+'||c=='-')
        return 1;
    if(c=='*'||c=='/')
        return 2;
    if(c=='(')
        return 3;
    if(c==')')
        return 4;
    return 0;
}
int main()
{
    char c;
    top=0;
    while(scanf("%c",&c)!=EOF&&c!='#')
    {
        if(c<='z'&&c>='a')              //如果是字母直接输出
            printf("%c",c);
        else
        {
            if(top==0)                   //如果是第一个字符就进栈
            {
                top++;
                stack[top]=c;
            }
            else  if(ch(c)>ch(stack[top]))       //即将入栈的符号与栈顶符号相比较
            {
                if(ch(c)==4)                     //如果是右括号,就将左括号之上的全部输出
                {
                    while(stack[top]!='(')
                    {
                        printf("%c",stack[top]);
                        top--;
                    }
                    top--;
                }
                else                             //否则进栈
                {
                    top++;
                    stack[top]=c;
                }
            }
            else                                
            {
                if(stack[top]!='(')               //如果不是左括号,那么先输出栈顶符号,再讲输入的符号入栈
                {
                    printf("%c",stack[top]);
                    stack[top]=c;
                }
                else                              //如果是左括号,则入栈
                {
                    top++;
                    stack[top]=c;
                }
            }
        }
    }
    while(top)                                    //最后,将栈里边的符号全部输出
    {
        printf("%c",stack[top]);
        top--;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值