题目描述
完美网络是连通网络的基础上要求去掉网络上任意一条线路,网络仍然是连通网络。求一个连通网络要至少增加多少条边可以成为完美网络。
输入
第一行输入一个数T代表测试数据个数(T<=20)。每个测试数据第一行2个数n,m 分别代表网络基站数和基站间线路数。基站的序号为从1到n。接下来m行两个数代表x,y 代表基站x,y间有一条线路。
(
0 < n < m < 10000)
输出
对于每个样例输出最少增加多少线路可以成为完美网络。每行输出一个结果。
示例输入
2 3 1 1 2 3 2 1 2 2 3
示例输出
2 1
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int st[12000];
int main()
{
int T,n,m,x,y;
scanf("%d",&T);
while(T--)
{
memset(st,0,sizeof(st));
priority_queue<int,vector<int>,greater<int> >s; //构造优先队列
scanf("%d %d",&n,&m);
while(m--)
{
scanf("%d %d",&x,&y);
st[x]++; //每个节点的入度数先加1
st[y]++;
}
sort(st+1,st+n+1); //对节点的入度数进行排序
for(int i=1;i<=n;i++)
{
if(st[i]<2) //只要是入度数小于2的就压进队列中,因为如果要构成完美图,那么每个节点的入度数要大于等于2
s.push(st[i]);
else
break;
}
int a,b,cnt=0;
while(s.size()>=2)
{
a=s.top(); //从队列中取出两个元素,因为一条边连接两个顶点
s.pop();
b=s.top();
s.pop();
a++;
b++;
cnt++;
if(a<2) //如果该节点的入度数还是小于2,继续压进队列
s.push(a);
if(b<2)
s.push(b);
}
if(!s.empty()) //如果队列中还剩余一个节点,那么条数也要加1
{
cnt++;
}
printf("%d\n",cnt);
}
return 0;
}
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int st[12000];
int main()
{
int T,n,m,x,y;
scanf("%d",&T);
while(T--)
{
memset(st,0,sizeof(st));
priority_queue<int,vector<int>,greater<int> >s; //构造优先队列
scanf("%d %d",&n,&m);
while(m--)
{
scanf("%d %d",&x,&y);
st[x]++; //每个节点的入度数先加1
st[y]++;
}
sort(st+1,st+n+1); //对节点的入度数进行排序
for(int i=1;i<=n;i++)
{
if(st[i]<2) //只要是入度数小于2的就压进队列中,因为如果要构成完美图,那么每个节点的入度数要大于等于2
s.push(st[i]);
else
break;
}
int a,b,cnt=0;
while(s.size()>=2)
{
a=s.top(); //从队列中取出两个元素,因为一条边连接两个顶点
s.pop();
b=s.top();
s.pop();
a++;
b++;
cnt++;
if(a<2) //如果该节点的入度数还是小于2,继续压进队列
s.push(a);
if(b<2)
s.push(b);
}
if(!s.empty()) //如果队列中还剩余一个节点,那么条数也要加1
{
cnt++;
}
printf("%d\n",cnt);
}
return 0;
}