Snowflake Snow Snowflakes(POJ--3349

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

题意:首先输入n表示有n个雪花,每个雪花有六个分支,每个分支有一定的长度,问这n个雪花中有没有一样的。

思路:用哈希表存储已经出现过的雪花,只要出现一样的后边的只管输入就不用进行判断了。不知道是poj的数据水啊还是题目描述的不符合要求我的代码只是判断了分支的大小就过了(QAQ啊),题目描述的是判断两个雪花是否一样时不仅要比较其分支大小还要比较其分支的顺序,而后台数据只是判断了分支的大小而并没有管分支的顺序,由于弱太渣了,不造怎么判断分支顺序,等日后能力提升了再回来更新博客吧

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 101000
#define H 1000073
using namespace std;

typedef struct node            //记录雪花信息
{
    int a[7];
    int next;
} Node;
Node node[N];
int n,cnt,hashtable[H],nade[7];
void init()                 //初始化
{
    memset(hashtable,-1,sizeof(hashtable));
    cnt=0;
}
void insertt(int *b,int h)       //如果没出现过就插入新雪花的信息
{
    for(int i=0; i<6; i++)
        node[cnt].a[i]=b[i];
    for(int i=0;i<6;i++)
    node[cnt].next=hashtable[h];
    hashtable[h]=cnt;
    cnt++;
}
int serch(int *b)                      //寻找看是否出现过
{
    int h=0;
    for(int i=0; i<6; i++)
    {
        h+=b[i]%H;
    }
    h=h%H;
    sort(nade,nade+6);
    int next,flag;
    next=hashtable[h];
    if(next!=-1)
    {
        while(next!=-1)
        {
            flag=1;
            for(int i=0; i<6; i++)
            {
                if(nade[i]!=node[next].a[i])
                {
                    flag=0;
                    break;
                }
            }
            if(flag)
                return 1;
            next=node[next].next;
        }
        insertt(nade,h);
    }
    else
        insertt(nade,h);
    return 0;
}
int main()
{
    //freopen("oo.text","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        int flag=0;
        init();                             //记得初始化
        while(n--)
        {
            for(int i=0; i<6; i++)
                scanf("%d",&nade[i]);
            if(flag)
                continue;
            if(serch(nade))
            {
                flag=1;
                printf("Twin snowflakes found.\n");
            }
        }
        if(!flag)
            printf("No two snowflakes are alike.\n");
    }
    return 0;
}<strong>
</strong>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值