Network Saboteur(POJ--2531

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.
题意:有n个点,任意两点之间都有权值,将所有点分为两个集合,求分成两个集合后两集合之间点的最大权值之和

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define MAX 0x3f3f3f3f
using namespace std;
int mmap[30][30];               //记录任意两点间的权值
int vis[30],ans,n;
void DFS(int pot,int sum)    //当前节点编号和此时的权值之和
{
    int s;
    if(pot>n)                       
    {
        ans=max(ans,sum);
        return ;
    }
    vis[pot]=1;                //将编号为pot的节点放入集合1中
    s=0;
    for(int i=1; i<pot; i++)
    {
        if(!vis[i])                //如果i节点在集合0中就加上这两点间的权值
        {
            s+=mmap[pot][i];
        }
    }
    DFS(pot+1,sum+s);
    vis[pot]=0;              <span style="font-family: Arial, Helvetica, sans-serif;">//将编号为pot的节点放入集合0中</span>
    s=0;
    for(int i=1; i<pot; i++)
        if(vis[i])               <span style="font-family: Arial, Helvetica, sans-serif;">//如果i节点在集合1中就加上这两点间的权值</span>
        {
            s+=mmap[pot][i];
            }
    DFS(pot+1,sum+s);

}
int main()
{
    //freopen("lalala.text","r",stdin);
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                scanf("%d",&mmap[i][j]);
        ans=0;
        memset(vis,0,sizeof(vis));
        DFS(1,0);
        printf("%d\n",ans);
    }
    return 0;
}<strong>
</strong>

另一种做法:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define MAX 0x3f3f3f3f
using namespace std;
int mmap[30][30];
int vis[30],ans,n;
int num()                                   //求此时两集合间任意两点的权值之和
{
    int s=0;
    for(int i=1; i<=n; i++)
    {
        if(vis[i])
            for(int j=1; j<=n; j++)
            {
                if(!vis[j])
                    s+=mmap[i][j];
            }
    }
    return s;
}
void DFS(int pot)
{
    if(pot==n)
    {
        int s=num();
        ans=max(ans,s);
        return ;
    }
    for(int i=0; i<2; i++)
    {
        vis[pot]=i;
        DFS(pot+1);
    }
}
int main()
{
    //freopen("lalala.text","r",stdin);
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                scanf("%d",&mmap[i][j]);
        ans=0;
        memset(vis,0,sizeof(vis));
        DFS(1);
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值