Cow Bowling(POJ--3176

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules
题意:输入n表示有n行数字,第i行有i个数字,有一头牛从第一行走到最后一行,它没走一个格就加上本格所代表的数字,这头牛只能向下或向右下方走一个格,求这头牛走过的所有格的数字加和最大是多少。
思路:开两个二维数组,一个是存储每个格子所代表的数字,另一个则存储到当前格子最大的数字加和。

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define INF 0x3f3f3f3f
#define esp 1e-9
using namespace std;
int a[400][400],b[400][400];
int main()
{
    //freopen("lalala.text","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=1; i<=n; i++)    
            for(int j=1; j<=i; j++)
                scanf("%d",&a[i][j]);
        b[1][1]=a[1][1];
        for(int i=2; i<=n; i++)
            for(int j=1; j<=i; j++)
                b[i][j]=a[i][j]+max(b[i-1][j],b[i-1][j-1]);    //当前格子的最大数字加和就等于当前格子的数字加上上边格子与右上方格子中数字最大的数
        int mm=-1;
        for(int i=1; i<=n; i++)     //遍历最后一行,寻找最大数字加和
            if(b[n][i]>mm)
                mm=b[n][i];
        printf("%d\n",mm);
    }

    return 0;
}<strong>
</strong>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值