Monthly Expense(POJ--3273【二分查找】

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.
题意:FJ想将n天分成m份,使得每一份的总共花销不超过一个数,求这个数最少是多少。
思路:二分查找满足要求的这个数。

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

<span style="font-size:18px;">#include <cstdio>
using namespace std;
int n,m,money[110000];
bool isok(int x)
{
    int sum=0,cnt=1;
    for(int i=1; i<=n; i++)
    {
        if(sum+money[i]<=x)         //如果此时累加的花销还没有超过x则接着加
        {
            sum+=money[i];
        }
        else                                    //如果超过了则sum等于当天的花销
        {
            sum=money[i];
            cnt++;                            //累计天数被分成了几份
            if(sum>x||cnt>m)        //如果当天花销已超过x或份数已超过规定份数则说明当前值x不满足要求
            return false;
        }
    }
    return true;
}
int main()
{
//freopen("lalala.text","r",stdin);
    int ans,l,r;
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&money[i]);
        l=0;                                       //这个数的下限
        r=2000000002;                   //这个数的上限
        while(l<=r)
        {
            int mid=(l+r)/2;              //不断二分
//            printf("mid = %d\n",mid);
            if(isok(mid))                    //如果满足要求看是否还有满足要求且比此时的数更小的数
            {
                r=mid-1;                    //减小上限
//                printf("r = %d\n",r);
                ans=mid;
//                printf("ans = %d\n",ans);
            }
            else                                //增大下限
                l=mid+1;
        }
        printf("%d\n",ans);
    }
    return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值