PAT 甲级 1039

PAT 甲级 1039

题目内容
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
输入
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
输出
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
例子
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题目分析
输入每个课程选课学生,输出每个学生的选课书。题目意思并不难,解法也不难,利用map最直接的解法。map是键值对,key-value。key是学生名字,value是学生的选课情况。很直接的想法就是map

#include <iostream>
#include <cstring>
#include <map>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int main(int argc, char *argv[]) {
    int n,k;
    cin>>n>>k;
    map<string,string> mymap;
    for(int i=0;i<k;i++){
        int courseid,totlestu;
        cin>>courseid>>totlestu;
        string st;
        stringstream ss;
        ss<<courseid;
        ss>>st;
        for(int j=0;j<totlestu;j++){
            string name;
            cin>>name;
            if(mymap.count(name)==0){
                mymap[name] = st;  
            }
            else{
                string s = mymap[name];
                s = s+st;
                mymap[name]= s;
            }
        }   
    }
    for(int i=0;i<n;i++){
        string name;
        cin>>name;
        if(mymap.count(name)==0){
            cout<<name<<" "<<0<<endl;
        }
        else{
            string s = mymap[name];
            sort(s.begin(),s.end());
            cout<<name<<" "<<s.length();
            for(int i=0;i<s.length();i++){
                cout<<" "<<s.at(i);
            }
            cout<<endl;
        }
    }
    return 0;
}

AC代码

#include <iostream>
#include <cstring>
#include <map>
#include <vector>
#include <algorithm>
#include <stdio.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;

int hashname(char name[4]){
    int sum = (name[0]-'A')*26*26*10 +
              (name[1]-'A')*26*10+
              (name[2]-'A')*10+
              (name[3]-'0');
    return sum;
}
//名字要哈希成整数 ,否则超时 
int main(int argc, char *argv[]) {
    map<int,vector<int> > mymap;
    int N,K;
    scanf("%d %d",&N,&K);
    for(int i=0;i<K;i++){
        int id,num;
        scanf("%d %d",&id,&num);
        for(int j=0;j<num;j++){
            char name[5];
            scanf("%s",name);
            int sname = hashname(name);
            vector<int> myvector = mymap[sname];
            myvector.push_back(id);
            mymap[sname] = myvector;
        }
    }
    for(int i=0;i<N;i++){
        char name[5];
    //  cin>>name;
        scanf("%s",name);
        int sname = hashname(name);
        vector<int> myvector = mymap[sname];
        sort(myvector.begin(),myvector.end());
        vector<int>::iterator it;
        printf("%s %d",name,myvector.size());
        //cout<<sname<<" "<<myvector.size();
        if(myvector.size()>0){
            for(it=myvector.begin();it!=myvector.end();it++){
            //cout<<" "<<*it;
            printf(" %d",*it);
            }
        }
        //cout<<endl;
        printf("\n");
    }
    return 0;
}

*心得体会
1.效率很重要,对于数据量越来越大的时代而言,追求高效越来越重要,因此基本功能完成的情况下必须要努力降低效率,使得时间更少。
2.基本数据结构的处理时间短,因此利用题目中已有的条件尽可能把非基本数据类型转换为基本数据类型,处理速度更高。哈希无疑是对于大数据量处理的一个好的方法。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值