更新package.json中的dependencies依赖到最新版本

当新建一个项目的时候,有时候会从其他项目的package.json里面copy一份dependencies过来。
但因为是新项目,我们想用各个依赖包的最新版本。如果手动去修改dependencies中各个包的版本号,那就太麻烦了,借助npm-check-updates工具可以很方便的将package.json中的依赖包版本号更新为最新版本。

安装:
npm install -g npm-check-updates

使用:

检查package.json中dependencies的最新版本:
ncu

更新dependencies到新版本:
ncu -u

更新全部dependencies到最新版本(包括当前指定版本范围满足最新版本号的,比如^4.2.0 -> ^4.3.0):
ncu -a
发布了12 篇原创文章 · 获赞 5 · 访问量 7万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览